SHESHUI.ME

APC extension PHP

/

错误信息

在捣腾一款新的CMS(Pagekie,基于Symfony框架)时,出现如下提示信息:

System Requirements

Your server doesn’t meet the minimum system requirements. Please fix the following issues to proceed.

Error APC version must be at least 3.1.13 when using PHP 5.4
Fix Upgrade your APC extension (3.1.13+).

解决方案

在PHP 5.4 版本中要求使用APC Extentsion版本为3.1.13 ,当前是3.3.9,所以去下载新版即可。

  • 下载地址: http://pecl.php.net/package/APC/3.1.13/windows
  • 下载版本:【5.4 Thread Safe (TS) x86】

下载后解压出 php_apc.dll 文件复制到 //php/ext/ 目录下即可(旧版文件可先做好备份)。

注:使用这个3.3.13版本的APC 扩展可能引发phpMyAdmin(在线Mysql管理应用)无法运行。

为做好兼容,最终决定注释掉改PHP扩展,修改php.ini 如下:

;extension=php_apc.dll

补充知识

APC,全称是Alternative PHP Cache,官方翻译叫”可选PHP缓存”。它为我们提供了缓存和优化PHP的中间代码的框架。 APC的缓存分两部分:系统缓存和用户数据缓存。

—— Updated 2017-11-16 06:18 ——

暂无留言。

非本文主题相关的留言请到:留言本

给我留言 Say something...

* 先[预览],后[提交]。

insert_comment